Internet Service -We have identified an issue with the fibre internet service at certain buildings.
Incident Report for Coextro
Resolved
This incident has been resolved.
Posted May 12, 2022 - 16:35 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 12, 2022 - 14:30 EDT
Investigating
We are investigating an issue with the internet service at certain buildings. The Coextro network team is currently working on resolving the issue as soon as possible. Please check back for updates.
Posted May 12, 2022 - 12:30 EDT
This incident affected: Internet (Fibre Internet).