Internet Service - identified service issue at 65/75/85 East Liberty and 125 Western Battery Rd
Incident Report for Coextro
Resolved
This incident has been resolved.
Posted Oct 04, 2022 - 22:04 EDT
Identified
We have identified a service issue with the internet service 65/75/85 East Liberty and 125 Western Battery Rd. The Coextro network team is currently working on resolving the issue as soon as possible. We do not have a time of resolution at this time. Please check back for updates.
Posted Oct 04, 2022 - 20:29 EDT
This incident affected: Internet (Fibre Internet).