Fiber Internet Outage- 360 Square One, 1 Micheal Power, and 3525 Kariya Dr
Incident Report for Coextro
Resolved
This incident has been resolved.
Posted May 17, 2022 - 18:55 EDT
Investigating
We are currently investigating this issue.
Posted May 17, 2022 - 18:01 EDT
This incident affected: Internet (Fibre Internet).