Internet Service - identified service issue [DSL Connection]
Incident Report for Coextro
Resolved
This incident has been resolved.
Posted Feb 24, 2020 - 17:36 EST
Identified
We have identified a service issue with the internet service [DSL connection]. The Coextro network team is currently working on resolving the issue as soon as possible. We do not have a time of resolution at this time. Please check back for updates.
Posted Feb 24, 2020 - 16:43 EST