Fiber Internet Outage- Georgina Island

Incident Report for Coextro

Resolved

This incident has been resolved.
Posted Apr 01, 2025 - 21:54 EDT

Identified

Our network gear for Georgina Island is currently offline due to hydro outage at the administrator office.
Posted Apr 01, 2025 - 09:42 EDT