Outage at 111 Elizabeth and 352 Front Toronto
Incident Report for Coextro
Resolved
This incident has been resolved.
Posted May 15, 2020 - 21:40 EDT
Investigating
We are currently investigating this issue.
Posted May 15, 2020 - 20:48 EDT
This incident affected: Internet (Fibre Internet).