Internet Service - possible service issue at 3880 Duke of York Blvd.

Incident Report for Coextro

Resolved

service is once again stable, monitoring as work continues in the building.
Posted Jun 02, 2026 - 12:26 EDT

Identified

3rd party contractors in building caused disruption in electrical closets in the building.
Posted Jun 02, 2026 - 12:26 EDT

Investigating

We are currently investigating a possible Internet service issue at 3880 Duke of York Blvd.
Our network team is reviewing the issue and working to restore normal service as soon as possible.
Thank you for your patience.
Posted Jun 02, 2026 - 10:53 EDT