Internet Service - identified service issue in Hamilton and Niagara area
Incident Report for Coextro
Resolved
This incident has been resolved. If you continue to have issues, please contact our Tech Support at 1-888-552-9516.
Posted Jan 30, 2024 - 15:50 EST
Update
The service to the Niagara customers has been restored.

Coextro is experiencing a fibre cut due to an accident impacting all services in the Hamilton area.

Cogeco techs are onsite coordinating efforts with hydro to resolve this issue, which involves crossing a highway and major roadways. The current estimated time of resolution is 3PM.
Posted Jan 30, 2024 - 10:47 EST
Identified
We have identified a service issue with the internet service using Cogeco lines in the Hamilton and Niagara areas. An accident cut a fibre line affecting all Cogeco ane related customers in the area.

The Cogeco team is currently working on resolving the issue as soon as possible and they have not provided an ETA at this time. Please check back for updates.
Posted Jan 30, 2024 - 07:42 EST
This incident affected: Internet (Cable Internet - Cogeco areas).