Internet Service - identified service issue

Incident Report for Coextro

Resolved

This incident has been resolved.
Posted Jul 13, 2026 - 13:02 EDT

Monitoring

A fix has been implemented, and Internet service is now up and running.
If your service is still not working, please reboot your modem/router. We are continuing to monitor the situation.

Thank you for your patience.
Posted Jul 13, 2026 - 07:59 EDT

Identified

We have identified a service issue with the internet service. The Coextro network team is currently working on resolving the issue as soon as possible. We do not have a time of resolution at this time. Please check back for updates.
Posted Jul 13, 2026 - 06:15 EDT
This incident affected: Internet (Fibre Internet, Cable Internet - Rogers areas, Cable Internet - Cogeco areas, DSL Internet).