Milton Ontario Outage
Incident Report for Coextro
Resolved
This incident has been resolved.
Posted Feb 28, 2023 - 08:55 EST
Investigating
We are currently investigating this issue.
Posted Feb 27, 2023 - 19:25 EST
This incident affected: Internet (Cable Internet - Cogeco areas).