Internet Service - possible service issue.

Incident Report for Coextro

Resolved

This incident has been resolved.
Posted Oct 04, 2025 - 09:47 EDT

Monitoring

The power outage has been resolved and we are monitoring the situation to ensure stability.
Posted Oct 04, 2025 - 03:28 EDT

Identified

Due to a power outage, internet is down at 3888 Duke of York, 3880 Duke of York, and surrounding buildings.
Estimated restoration (per power company ): Oct 4, 1 AM – 3 AM.
Posted Oct 03, 2025 - 23:11 EDT