Internet Service - identified service issue at 75/85/95 North Park
Incident Report for Coextro
Resolved
This incident has been resolved.
Posted Sep 09, 2021 - 14:42 EDT
Identified
We have identified a service issue with the fibre internet service at 75/85/95 North Park. The Coextro network team is currently working on resolving the issue as soon as possible. We do not have a time of resolution at this time. Please check back for updates.
Posted Sep 09, 2021 - 13:58 EDT
This incident affected: Internet (Fibre Internet).