Internet Service - identified service issue with the fibre internet at 1 Michael Power, 385 Prince of Wales, 3525 Kariya Drive
Incident Report for Coextro
Resolved
The incident has been resolved.
Posted Jun 28, 2020 - 11:41 EDT
Identified
We have identified a service issue with the the fibre internet at 1 Michael Power, 385 Prince of Wales, 3525 Kariya Drive. The Coextro network team is currently working on resolving the issue as soon as possible. We do not have a time of resolution at this time. Please check back for updates.
Posted Jun 28, 2020 - 09:53 EDT
This incident affected: Internet (Fibre Internet).