Internet Service - identified service issue at 385 Prince of Wales Drive
Incident Report for Coextro
Resolved
This incident has been resolved.
Posted Apr 06, 2021 - 17:06 EDT
Identified
We have identified a service issue with the fibre internet service at 385 Prince of Wales Drive. The Coextro network team is currently working on resolving the issue as soon as possible. We do not have a time of resolution at this time. Please check back for updates.
Posted Apr 06, 2021 - 16:38 EDT
This incident affected: Internet (Fibre Internet).