Internet Service - identified service issue at Neill-Wycik
Incident Report for Coextro
Resolved
This incident has been resolved.
Posted Feb 07, 2020 - 04:29 EST
Update
Our techs are currently on-site and we are continuing to work on the issue. We do not have an ETA at this time.
Posted Feb 06, 2020 - 23:17 EST
Identified
We have identified a service issue with the internet service at Neill-Wycik. The Coextro network team is currently working on resolving the issue as soon as possible. We do not have a time of resolution at this time. Please check back for updates.
Posted Feb 06, 2020 - 21:22 EST
This incident affected: Internet (Fibre Internet).