Please be advised that overnight maintenance will be performed at 525 Wilson Ave on Thursday, May 14, 2026, between approximately 2:00 AM and 4:00 AM to finalize the solution and complete a permanent fix.
We expect minimal to no service interruption during this work. Our network team will be on standby throughout the maintenance window in case any issues arise.
Thank you for your patience and understanding
Posted May 13, 2026 - 18:09 EDT
Update
A solution has been implemented for the Internet service issue at 525 Wilson Ave. If your Internet service is still not working, please call our technical support team at 1-888-552-9516, and they will be happy to resolve the issue. Thank you for your patience.
Posted May 12, 2026 - 14:21 EDT
Update
A solution has been implemented for the Internet service issue at 525 Wilson Ave. If your Internet service is still not working, please call our technical support team at 1-888-552-9516, and they will be happy to resolve the issue. Thank you for your patience.
Posted May 12, 2026 - 14:20 EDT
Identified
We’re currently investigating an Internet service issue at 525 Wilson Ave. Our team is working to restore service as quickly as possible.