Internet Service - identified service issue at 125 Western Battery Road
Incident Report for Coextro
Resolved
This incident has bee resolved.
Posted Jul 27, 2020 - 18:54 EDT
Identified
We have identified a service issue with the fibre internet service at 125 Western Battery Road. The Coextro network team is currently working on resolving the issue as soon as possible. We do not have a time of resolution at this time. Please check back for updates.
Posted Jul 27, 2020 - 14:47 EDT
This incident affected: Internet (Fibre Internet).