Outage for Georgina Island.
Incident Report for Coextro
Resolved
This incident has been resolved.
Posted Jul 02, 2023 - 17:51 EDT
Investigating
We are currently investigating this issue.
Posted Jul 02, 2023 - 14:10 EDT
This incident affected: Internet (Fibre Internet).