Internet Service - identified service issue with some customers at 85 East Liberty
Incident Report for Coextro
Resolved
This incident has been resolved.
Posted Jul 28, 2020 - 12:53 EDT
Identified
We have identified a service issue with the fibre internet service with some customers at 85 East Liberty. The Coextro network team is currently working on resolving the issue as soon as possible. We do not have a time of resolution at this time. Please check back for updates.
Posted Jul 28, 2020 - 10:49 EDT
This incident affected: Internet (Fibre Internet).