Outage at 3888/3880 Duke of York and 310/330 Burnhamthorpe
Incident Report for Coextro
Resolved
This incident has been resolved.
Posted May 15, 2023 - 09:26 EDT
Investigating
We are currently investigating this issue.
Posted May 15, 2023 - 07:10 EDT
This incident affected: Internet (Fibre Internet).