19 Singer Court - Fibre Internet
Incident Report for Coextro
Resolved
This incident has been solved. We thank you for your patience.
Posted Jul 24, 2020 - 14:19 EDT
Update
We are continuing to work on a fix for this issue.
Posted Jul 24, 2020 - 13:40 EDT
Identified
The issue has been identified and a fix is being implemented. There is currently no ETA but we are working as fast as possible to restore service. We thank you for your patience and we apologize for the inconvenience. Update will follow once it becomes available.
Posted Jul 24, 2020 - 13:37 EDT
This incident affected: Internet (Fibre Internet).