Internet Service - possible service issue at 385 Prince of Wales
Incident Report for Coextro
Resolved
This incident has been resolved.
Posted Sep 21, 2022 - 16:21 EDT
Investigating
We are investigating an issue with the fibre internet service at 385 Prince of Wales. Please check back for updates.
Posted Sep 21, 2022 - 15:43 EDT
This incident affected: Internet (Fibre Internet).