Internet Service - We’re currently investigating a possible service issue.

Incident Report for Coextro

Resolved

This incident has been resolved.
Posted May 04, 2026 - 15:36 EDT

Identified

We’re currently investigating a possible service issue affecting the following locations:

75, 85 & 95 North Park Rd
4065 & 4099 Brickstone Mews
385 Prince of Wales Dr
3880 & 3888 Duke of York Blvd
310 & 330 Burnhamthorpe Rd
15, 19, 25, 29 & 33 Singer Crt

Our team is actively working to identify the cause and restore service as quickly as possible. We appreciate your patience and will provide updates as soon as more information becomes available.
Posted May 04, 2026 - 14:15 EDT