Emergency maintenance for fiber buildings,
Incident Report for Coextro
Resolved
This incident has been resolved. If your service has not been restored, please power cycle your router. If that does not resolve your issues, please contact technical support at 1-888-552-9516. Thank you for your patience.
Posted May 27, 2023 - 18:27 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 27, 2023 - 11:35 EDT
Investigating
We will be performing an emergency maintenance at 11am lasting no more then 30 minutes
Posted May 27, 2023 - 10:41 EDT
This incident affected: Internet (Fibre Internet).